This website uses cookies to distinguish you from other users of our website. The use of cookies helps us to provide you with a specific service, to facilitate website use, to understand our visitors and to advertise to you. By continuing to browse the site you are giving consent to our use of cookies. Learn more in our Privacy Statement.

Security Services

Multiple Vendor WebKit HTML Element Use After Free Vulnerability



WebKit is an open source web browser engine. It is currently used by Apple Inc.'s Safari browser, as well as by Google's Chrome browser. For more information, see the vendor's site at the following link.


Remote exploitation of a memory corruption vulnerability in WebKit, as included with multiple vendors' browsers, could allow an attacker to execute arbitrary code with the privileges of the current user.

The vulnerability occurs when a certain property of an HTML element is reset via JavaScript code. When this occurs, a C++ object is incorrectly accessed after it has been freed. This results in an attacker controlled value being used as a C++ VTABLE, which leads to the execution of arbitrary code.


Exploitation of this vulnerability results in the execution of arbitrary code with the privileges of the user viewing the Webpage. To exploit this vulnerability, a targeted user must load a malicious Webpage created by an attacker. An attacker typically accomplishes this via social engineering or injecting content into compromised, trusted sites. After the user visits the malicious Webpage, no further user interaction is needed.

Exploitation of this vulnerability is relatively simple if a heap spray technique is used to control large portions of heap memory. It is also trivial for an attacker to reallocate the chunk of freed memory and populate it with controlled values. This allows an attacker to control a C++ VTABLE, which leads to code execution. As such, iDefense considers this vulnerability to be highly exploitable.


iDefense has confirmed the existence of this vulnerability in Google Chrome and Safari 4.0.4. Previous versions are suspected to be vulnerable. A full list of affected Apple products can be found in Security Advisory APPLE-SA-2010-03-11-1 Safari 4.0.5.


The vulnerability is present in the JavaScript engine, so disabling JavaScript is an effective workaround. This can be performed via the command line with Google Chrome, and the Preferences menu in Safari.


Apple Inc. has released a patch which addresses this issue. Information about downloadable vendor updates can be found by clicking on the URLs shown.


The Common Vulnerabilities and Exposures (CVE) project has assigned the name CVE-2010-0049 to this issue. This is a candidate for inclusion in the CVE list (, which standardizes names for security problems.


12/15/2009 Initial Vendor Notification
12/15/2009 Initial Vendor Reply
03/11/2010 Coordinated Public Disclosure


This vulnerability was reported to iDefense by wushi&Z of team509.

Get paid for vulnerability research

Free tools, research and upcoming events


Copyright © 2010 Verisign, Inc.

Permission is granted for the redistribution of this alert electronically. It may not be edited in any way without the express written consent of iDefense. If you wish to reprint the whole or any part of this alert in any other medium other than electronically, please e-mail customer service for permission.

Disclaimer: The information in the advisory is believed to be accurate at the time of publishing based on currently available information. Use of the information constitutes acceptance for use in an AS IS condition. There are no warranties with regard to this information. Neither the author nor the publisher accepts any liability for any direct, indirect, or consequential loss or damage arising from use of, or reliance on, this information.